Unable to access Mail Management Site
Incident Report for Virtual Post Mail
Resolved
This incident has been resolved.
Posted 11 months ago. Aug 08, 2017 - 08:45 PDT
Monitoring
A fix have been deployed and appears to be working. You can access the mail management site now. We will be monitoring for a short period of time to make sure it's working.
Posted 11 months ago. Aug 08, 2017 - 08:41 PDT
Identified
We've identified the issue and are in the middle of deploying a fix to our servers.
Posted 11 months ago. Aug 08, 2017 - 08:39 PDT
Investigating
Our site is currently redirecting user to the incorrect site for mail management. We are aware of the issue and investigating as we speak.
Posted 11 months ago. Aug 08, 2017 - 08:33 PDT