Reduced Capacity Affecting Processing Times
Incident Report for Virtual Post Mail
Resolved
Delaware is now back to normal operational processing times. We do apologize for the delays and thank you for your patience.
Posted Mar 10, 2020 - 08:53 PDT
Identified
We are experiencing some slowdown in processing your requests at our Delaware facility. We do apologize for this. So far, all our other locations still have sufficient capacity to handle the expected load and should not be affected.

We take both our service quality very seriously. So we do apologize if service is delayed and appreciate your patience and understanding.
Posted Mar 09, 2020 - 08:38 PDT
This incident affected: Locations (Claymont, DE).