VPM.COM Website Down
Incident Report for Virtual Post Mail
Resolved
This incident has been resolved.
Posted almost 3 years ago. Dec 25, 2015 - 17:07 PST
Monitoring
Website is back up. We're monitoring network connections to make sure it stays up.
Posted almost 3 years ago. Dec 25, 2015 - 12:48 PST
Identified
One of our server providers, Linode, is having a major outage at this time. We are awaiting status from them. During this time, if you need to login to manage your mail, please access our mail management site directly at https://my.virtualpostmail.com/
Posted almost 3 years ago. Dec 25, 2015 - 12:28 PST