Disruption in Delaware Operations Due to Increment Weather
Incident Report for Virtual Post Mail
Resolved
Delaware Operations is now back online as the snow storm has subsided and roads are cleared. We will begin processing all pending requests and induct new mail. Thank you for your patience.
Posted Feb 03, 2021 - 05:59 PST
Update
Our operations in Delaware will close for today. Heavy snow conditions continue to plague the Delaware region. Roads are still not being plowed in our area and people are not able to get to work. All scan and shipping requests will be on hold for one more day.

Based on weather advisory, we expect today to be the last day.
Posted Feb 02, 2021 - 08:26 PST
Monitoring
There is a heavy snowstorm in the east coast region affecting our Delaware location. Roads and transportation are severely affected.

Out of concern for our staff, we are sending them home early today so they do not get stuck at the office.

This means:

* Most shipments have been shipped out where possible. Any new shipments will not be processed today.
* Most scanning requests were processed, but some cannot be completed. Any new scanning requests will not be processed today.
* Weather advisory has indicated that the snowstorm is expected to last into Tuesday. Therefore, Tuesday processing may also possibly be delayed.

We will keep an eye out on the weather conditions, and keep you posted here on any changes.

Thank you.
Posted Feb 01, 2021 - 09:02 PST
This incident affected: Locations (Claymont, DE).