Major Power Outage Affecting Henderson Facility
Incident Report for Virtual Post Mail
Resolved
Power has been restored. We will begin processing all pending requests at this time at our Henderson facility.
Posted Nov 20, 2019 - 11:37 PST
Monitoring
A major power outage has occurred in the City of Henderson affecting roughly 3700 households. This started around midnight. We are unfortunately affected by this as well.

Currently, we will not be able to process any requests at our Henderson location until power is restored. Scanning request processing will be delayed.

The power company has given an estimated restoration time of 10:45am local time.
Posted Nov 20, 2019 - 08:34 PST
This incident affected: Locations (Henderson, NV).