Internet Network Outage at Henderson
Incident Report for Virtual Post Mail
Resolved
Our internet network has been restored. We'll begin processing all backlogged requests at this time. Things may possibly be delayed but should all be completed before the end of the day.
Posted 6 months ago. Jan 22, 2019 - 12:00 PST
Update
Our internet network is still down. We are still working with our service provider to get things going.

Request processing continues to be delayed for the moment.

We will keep posting updates.
Posted 6 months ago. Jan 22, 2019 - 11:08 PST
Identified
We are currently experiencing an internet network outage out of our Henderson Processing Center. We are actively reaching out to get this resolved with our network provider.

Shipping and scanning requests cannot be processed at this time.

We currently do not have an estimated time when this will be resolved. We will keep you posted on updates as we know more.
Posted 6 months ago. Jan 22, 2019 - 09:02 PST
This incident affected: Locations (Henderson, NV).