Amazon Web Services Outage
Incident Report for Virtual Post Mail
Resolved
AWS appears to be recovering at this time. Mail envelope images is loading well now as well as PDF file downloads. We will continue monitoring.
Posted about 1 year ago. Feb 28, 2017 - 16:06 PST
Update
We're still seeing high percentage of error rates for serving out mail envelope images caused by our cloud hosting provider Amazon Web Services (AWS). However, we're able to start processing some new mail and scanning requests at this time. New mail uploads and scanning request may be partially delayed today. Shipments should go out without delay today.

We will continue to monitor status and keep you posted.
Posted about 1 year ago. Feb 28, 2017 - 15:23 PST
Monitoring
Outage at Amazon Web Services is causing partial site issues with mail image loading and PDF file downloading. We're waiting on AWS to resolve their problems and will give updates as we hear them. But at the moment, it looks like the problem is clearing up and we're seeing reduced errors.
Posted about 1 year ago. Feb 28, 2017 - 14:34 PST