Electrical Power Outage in Los Angeles
Incident Report for Virtual Post Mail
Resolved
This incident has been resolved.
Posted 9 months ago. Aug 28, 2017 - 11:22 PDT
Update
Power is now back up at our processing center. We will continue to monitor the situation.

Processing may be slightly delayed for scanning request, but we will catch up shortly.
Posted 9 months ago. Aug 28, 2017 - 11:06 PDT
Monitoring
We have a major electrical power outage at our Los Angeles processing facility. At this time, all power is off. Processing of scanning requests and shipments may be delayed. Electric company has indicated that power is estimated to come back up at 2pm PDT. We certainly hope it'll be sooner.

We will keep you posted on the status when power is back on. Meanwhile, we are investigating options to allow us to do partial processing of requests.
Posted 9 months ago. Aug 28, 2017 - 10:38 PDT