Delaware Processing Center Closing Early
Incident Report for VirtualPostMail
Resolved
Unfortunately, severe snow storm continued on Monday, Jan 6. So our Delaware Operations are also closed for the day.

Delaware processing center will be back to normal on Tuesday, Jan 7, 2025.
Posted Jan 03, 2025 - 16:23 PST
Identified
Due to severe weather conditions coming into Delaware, we have decided to close the processing center early for the employee's safety. We will come back on Monday to continue with any unfinished requests.
Posted Jan 03, 2025 - 10:47 PST
This incident affected: Locations (Claymont, DE).