Florida location closure due to tropical storm Idalia
Incident Report for VirtualPostMail
Resolved
Brandon office was not impacted by the hurricane and we were back in operation on Thursday
Posted Sep 01, 2023 - 05:07 PDT
Update
Brandon office is closed for Wednesday. We expect to be back on Thursday to continue processing all requests.
Posted Aug 30, 2023 - 15:22 PDT
Investigating
Tropical storm Idalia is expected to make landfall near our Brandon, FL location (near Tampa) late Tuesday or early Wednesday. For the safety of our staff on-site, we may close on Tuesday afternoon. We will be closed all of Wednesday and will monitor whether it's safe to return on Thursday.
Posted Aug 28, 2023 - 11:39 PDT
This incident affected: Locations (Brandon, FL).