Severe weather continues to affect the area. Our office closure will extend to Tuesday. We will monitor and continue checking to see if Wednesday will be a viable return date.
Posted Jan 26, 2026 - 09:34 PST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 26, 2026 - 00:00 PST
Scheduled
For the safety of our staff, our Keller Texas office is scheduled to be closed on Monday, Jan 26, 2026 due to inclement weather conditions. There is a severe winter storm heading into Texas over the weekend. For now, we are actively monitoring the situation and will determine whether office closure will extend to Tuesday or later.
We'll keep everyone updated as we go.
Posted Jan 23, 2026 - 14:29 PST
This scheduled maintenance affects: Locations (Keller, TX).