Delaware Processing Center Closed Due to Inclement Weather

Incident Report for VirtualPostMail

Resolved

Our Claymont, DE location is back to normal operational status today.
Posted 2 months ago. Feb 13, 2025 - 07:42 PST

Monitoring

Due to severe weather and unsafe road conditions, our Delaware location will be closed for today. We expect to be back tomorrow to continue processing.
Posted 2 months ago. Feb 12, 2025 - 10:06 PST
This incident affected: Locations (Claymont, DE).