Disruption in Henderson Operations Due to Personnel on Sick Leave
Incident Report for VirtualPostMail
Resolved
Operations should continue on Monday morning.
Posted Feb 05, 2022 - 10:18 PST
Monitoring
Unfortunately, our Henderson Operations personnel have all taken sick leave for safety and health reasons. We have temporarily closed our Henderson operations for today and expect to have some of our personnel back on Monday to process mail. We do apologize for the inconvenience. Please reach out to our Customer Support if you have any questions.
Posted Feb 04, 2022 - 10:06 PST
This incident affected: Locations (Henderson, NV).