Office Closure Due to Tropical Storm Nicole
Incident Report for VirtualPostMail
Resolved
Tropical Storm Nicole has passed. We did not encounter any damages or issues at our facility, so all mail is secure. We will be back on Monday to process any pending requests.
Posted Nov 11, 2022 - 11:43 PST
Investigating
Tropical Storm Nicole is expected to land in Tampa area on Thursday. For the safety of our people, we have decided to close for Thursday. Friday is a holiday and is closed.
Posted Nov 09, 2022 - 17:00 PST
This incident affected: Locations (Brandon, FL).