Power has been restored as of last night. Our Brandon office sustained minor damages externally but customer mail on-site was not damaged and remained safe. But it is now operational starting today.
Mail for the past 2 days were transferred to another processing center and most of it have been processed. Any new mail that arrives today will be processed again on site. Any scan and shipping requests that were pending since last week will also be processed today as well. We should be able to catch up either today or tomorrow at the latest.
Posted Oct 17, 2024 - 10:41 PDT
Update
As of today, Tuesday October 15, it looks like a large portion of our area has their power restored. Unfortunately, power has not yet been restored for our office. The power company has indicated that they are on track restoring power to all customers by Thursday.
In the meantime, we have scheduled our people to return to the office to assess any damages, if any, and to look at taking the next steps in seeing whether we can begin processing mail. Our current plan is to see if we can retrieve all new mail from the post office. Once we get a hold of new mail, we will be transferring them to another one of our processing centers for processing. We expect this to create a one day delay for the mail transfer.
We will continue to keep you updated on the situation.
Posted Oct 15, 2024 - 02:25 PDT
Update
Our power company has provided an updated status on the power restoration. Based on their estimates, 55% of the affected customers in our county will have power restored by Sunday (Oct 13) and 75% will have power restored by Tuesday. We certainly hope that our power will be restored sooner rather than later.
We'll continue to provide updates as we find out more information.
Posted Oct 12, 2024 - 12:16 PDT
Update
Power is still out for a majority of the Tampa residents. There is currently no timeline in terms of when power will be back up.
There was a quick preliminary check of our office and looks like the building is intact with no exterior damage and no broken windows and doors. Internal facility equipment and customer mail should all be fine.
Operations still cannot continue due to the power outage. All couriers have also suspended operations in our area, so there won't be any mail delivery at this time.
We will continue to keep you posted if we have any new updates.
Posted Oct 10, 2024 - 14:43 PDT
Monitoring
Hurricane Milton has unfortunately passed directly through the Tampa/Brandon area and caused major disruption to the entire area. We are currently experiencing power outage that is affecting over 3 million residents and businesses, including ours. It is currently unknown when power will be restored again. Communication is cutoff to any employee that's within the area.
The storm is expected to pass the area by Thursday morning (Eastern Time). We do not anticipate that we will be able to access the office for the time being due to flooding and debris. There's no way to assess any damages or understand the impact at the office right now.
We have extended our office closure to next Monday (we are not open during weekends and holidays) at this time. We'll keep you posted on the update of the situation as soon as our people are able to safely return back to the office.