Claymont, DE is experiencing technical difficulties processing requests
Incident Report for VirtualPostMail
Resolved
This incident has been resolved.
Posted Oct 22, 2019 - 17:57 PDT
Update
Issue has been resolved. We continue to monitor the network situation. As operations is closed over the weekend, we will process all pending requests on Monday. We apologize for the delay.
Posted Jun 29, 2019 - 08:13 PDT
Update
Our network is still not yet resolved by the network provider. We continue to monitor the situation, but at this time, request processing may likely be delayed until the next business day.
Posted Jun 28, 2019 - 10:51 PDT
Identified
We are experiencing technical and network issues with our office in Claymont, DE office. At the moment, we're not able to process requests. All request processing may be delayed. We've actively reached out to get this resolved, but the resolution time is unknown. We will post more info as we get them.
Posted Jun 28, 2019 - 07:49 PDT
This incident affected: Locations (Claymont, DE).