Brandon, FL Office closed due to Hurricane Ian
Incident Report for VirtualPostMail
Resolved
Hurricane Ian has passed. Our office is open for today. There were luckily no damages.
Posted Sep 30, 2022 - 09:07 PDT
Monitoring
Hurricane Ian is already hitting our Florida office. With hurricane warning in place along with high winds and storm surge potential, we have decided to close our office for Wednesday and Thursday to ensure the safety of our staff.

Shipping carriers have already announced service suspension until further notice. You can track this information on service status here:

USPS: https://about.usps.com/newsroom/service-alerts/residential/welcome.htm
UPS: https://www.ups.com/us/en/service-alerts.page
FedEx: https://www.fedex.com/en-us/service-alerts.html

All requests will not be processed until it is safe for our people to return back to the office.

We have taken measures to cover all the mail to make sure they stay dry.
Posted Sep 28, 2022 - 05:24 PDT
This incident affected: Locations (Brandon, FL).