Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 25, 2024 - 00:00 PDT
Scheduled
Due to Major Helene, which can possibly turn into a Hurricane by landfall on Thursday, our Florida office is scheduled to close for 2 days, Sep 25 and 26. We will be monitoring the storm closely to make sure that everything is good.
In the event that the storm swerve and if weather conditions allow, we may reopen our office earlier.
During this time period, no mail processing will occur. It's expected that the post office will not open and deliver mail either.
Posted Sep 24, 2024 - 13:05 PDT
This scheduled maintenance affected: Locations (Brandon, FL).