Unscheduled maintenance
Incident Report for VirtualPostMail
Resolved
Maintenance has been completed and all systems are back online. Thank you for your patience.
Posted Jul 04, 2023 - 16:26 PDT
Identified
We are currently performing unscheduled maintenance of our backend servers. It is expected to take a couple hours. We apologize for the inconvenience.
Posted Jul 04, 2023 - 14:57 PDT
This incident affected: Mail Management UI.