No mail delivery by USPS to KEL processing center
Incident Report for VirtualPostMail
Resolved
This incident has been resolved.
Posted Apr 02, 2024 - 09:51 PDT
Update
USPS has finally released the mail. We were able to pick up the accumulated mail. We have already started to sort through the mail and will begin to process and scan the mail into your mailbox. Thank you for all your patience and understanding.
Posted Apr 02, 2024 - 09:51 PDT
Update
Over the weekend, we see that the post office has finally did their job to submit and upload our documents into their postal database.

We visited the post office again this morning. The postmaster said that he needs to make a call today to HQ to check if all the forms are approved. He then mentioned that mail should be released either today or tomorrow. We will head to the post office tomorrow again should we no see mail come in today.
Posted Apr 01, 2024 - 12:35 PDT
Update
We've visited the post office this morning again requesting for mail to just be given to us instead. They indicated that they still require additional form(s) to be completed but have no idea which one(s). They did visit our office later in the morning to have a form signed.

The supervisor has indicated that they have all the documents at this time. We requested for a timeline on when the mail will be released but they did not provide an estimate or confirm if they can release the mail on Monday.

We have reached out again to the USPS Consumer Affairs/Advocacy to see if they can get this escalated and pushed. We'll continue to keep you updated.
Posted Mar 29, 2024 - 12:13 PDT
Update
Unfortunately, it does not look like we received mail for Keller office today as promised. We will head back to the post office tomorrow morning to request for information and ask whether we can just pick up the mail directly on-site. We will keep you posted.
Posted Mar 28, 2024 - 14:43 PDT
Update
We are visiting the post office everyday to get mail delivery resumed again. The USPS supervisor has indicated that mail should be delivered today. We are still waiting for the mail delivery to happen. We'll keep you posted as events unfold.
Posted Mar 28, 2024 - 11:18 PDT
Monitoring
We have noticed an unusual situation at our Keller, TX office where mail delivery from the local post office has stopped as of this past week.

After inquiring about the issue in person, we were told that they are holding our mail (or our customers' mail in this case). After many attempts in reaching out to them, we are able to identify the reason for their suspension of delivery to us.

At this time, we are actively resolving the situation with the local post office to get mail delivery going again.

We believe we are getting close to resolution, but we're still waiting on them to release the mail. We will keep you posted on this.
Posted Mar 26, 2024 - 14:28 PDT
This incident affected: Locations (Keller, TX).