Login and Image Loading not working
Incident Report for VirtualPostMail
Resolved
Site is now up and running. Thank you for your patience.
Posted Jun 13, 2023 - 14:14 PDT
Identified
There is currently an outage occurring at our cloud service provider, Amazon Web Services. Due to their outage, parts of our system is currently not functioning, including login and image loading. They have identified the issue and is fixing this. We do not yet know the time it will take for them to fix this, but we will keep you updated.

This will also affect some of our request processing, so mail and scanning/shipping requests may be delayed.
Posted Jun 13, 2023 - 13:22 PDT
This incident affected: Locations (Brandon, FL, Claymont, DE, Covina, CA, Henderson, NV) and Mail Management UI.